Latest 0.1.0
Homepage https://github.com/xilin/binance-objc-api
License MIT
Platforms ios 8.0, requires ARC
Dependencies JSONModel, YTKNetwork, CocoaLumberjack, YYCategories, BlocksKit, SocketRocket
Frameworks CoreFoundation
Authors

Binance Objective-C API

BinanceApiClient is a lightweight client lib for Binance.com, which fullfill all the APIs provided by Binance.

Features

  • Support all the RESTful Public API Endpoints listed in Binance API.

  • Support all the WebSocket API listed in Binance API.

Examples

Please refer to BARestClientTest.m/BAWebSocketClientTest.m in Example folders for more details.

Installation

BinanceApiClient is available through CocoaPods. To install
it, simply add the following line to your Podfile:

pod 'BinanceApiClient'

Author

[email protected]

License

BinanceApiClient is available under the MIT license. See the LICENSE file for more info.

Latest podspec

{
    "name": "BinanceApiClient",
    "version": "0.1.0",
    "summary": "A lightweight client lib for Binance.com",
    "description": "BinanceApiClient is a lightweight client lib for Binance.com,n which fullfill all the APIs provided by [Binance](https://www.binance.com/restapipub.html).",
    "homepage": "https://github.com/xilin/binance-objc-api",
    "license": {
        "type": "MIT",
        "file": "LICENSE"
    },
    "authors": {
        "XiLin": "[email protected]"
    },
    "source": {
        "git": "https://github.com/xilin/binance-objc-api.git",
        "tag": "0.1.0"
    },
    "platforms": {
        "ios": "8.0"
    },
    "source_files": "BinanceApiClient/Classes/**/*",
    "exclude_files": "Example",
    "public_header_files": "BinanceApiClient/Classes/**/*.h",
    "frameworks": "CoreFoundation",
    "dependencies": {
        "JSONModel": [
            "~> 1.7.0"
        ],
        "YTKNetwork": [
            "~> 2.0.4"
        ],
        "CocoaLumberjack": [
            "~> 2.3.0"
        ],
        "YYCategories": [
            "~> 1.0.4"
        ],
        "BlocksKit": [
            "~> 2.2.0"
        ],
        "SocketRocket": [
            "~> 0.5.1"
        ]
    },
    "requires_arc": true
}

Pin It on Pinterest

Share This