Latest 1.7
Homepage https://github.com/JQHee/BFRefresh
License MIT
Platforms ios 8.0
Dependencies SnapKit
Authors

Version
License
Platform

Screenshots

result.gif

Requirements

BFRefresh works on "Xcode 9.3.1 , Swift 4 and ios 8+ to build.
You will need the latest developer tools in order to build BFRefresh. Old Xcode versions might work, but compatibility will not be explicitly maintained.

CocoaPods

CocoaPods is the recommended way to add BFRefresh to your project.

Add a pod entry for BFRefresh to your Podfile.

pod 'BFRefresh'

Second, install BFRefresh into your project:

pod install

Manually

  1. Download the latest code version .
  2. Open your project in Xcode,drag the JQProgressHUD folder into your project. Make sure to select Copy items when asked if you extracted the code archive outside of your project.

Usage

tableView.set(loadType: .normal)

tableView.refreshBlock = { [weak self] in
    print(self ?? "")
}

For more examples, including how to use BFRefresh , take a look at the bundled demo project. API documentation is provided in the header file (UIScrollView-BFRefresh.swift).

License

BFRefresh is released under the MIT. See LICENSE for details.

Latest podspec

{
    "name": "BFRefresh",
    "version": "1.7",
    "summary": "u5217u8868u7684u52a0u8f7du63d0u793a",
    "swift_version": "4.2",
    "homepage": "https://github.com/JQHee/BFRefresh",
    "license": "MIT",
    "authors": {
        "huangjiaqian": "[email protected]"
    },
    "platforms": {
        "ios": "8.0"
    },
    "source": {
        "git": "https://github.com/JQHee/BFRefresh.git",
        "tag": "1.7"
    },
    "source_files": "BFRefresh/**/*.swift",
    "resources": "BFRefresh/Resource/*",
    "dependencies": {
        "SnapKit": []
    }
}

Pin It on Pinterest

Share This