Latest 1.1
Homepage https://github.com/Rivukis/AppUpgradable
License MIT
Platforms ios 9.0
Authors

Version
License
Platform

Convenient way to migrate your app from one version to the next.

AppUpgradable allows an app to easily and efficiently migrate from the last installed version to the newly installed version. It allows the migration function code to report out non-fatal errors and fatal errors. It allows the migrator to condense upgrades of multiple versions to help with performance. It has a single function to upgrade the app and returns the overall result.

Conforming to AppUpgradable

// TODO: fill out explanation and examlpe code.

Tests

// TODO: write tests (currently manually testing functionality in the playground)

To see and run the tests for AppUpgradable. Download the playground and run it. The tests are written using Deft.

Requirements

  • Xcode 9
  • Swift 4

Installation

AppUpgradable is available through CocoaPods. To install
it, simply add the following line to your Podfile:

platform :ios, "9.0"
use_frameworks!

target "<YOUR_TARGET>" do
    pod "AppUpgradable"
end

Author

Brian Radebaugh, [email protected]

License

AppUpgradable is available under the MIT license. See the LICENSE file for more info.

Latest podspec

{
    "name": "AppUpgradable",
    "version": "1.1",
    "summary": "Convenient way to migrate your app from one version to the next.",
    "description": "AppUpgradable allows an app to easily and efficiently migrate from the last installed version to the newly installed version. It allows the migration function code to report out non-fatal errors and fatal errors. It allows the migrator to condense upgrades of multiple versions to help with performance. It has a single function to upgrade the app and returns the overall result.",
    "homepage": "https://github.com/Rivukis/AppUpgradable",
    "license": {
        "type": "MIT",
        "file": "LICENSE"
    },
    "authors": {
        "Brian Radebaugh": "[email protected]"
    },
    "source": {
        "git": "https://github.com/Rivukis/AppUpgradable.git",
        "tag": "1.1"
    },
    "platforms": {
        "ios": "9.0"
    },
    "swift_version": "4.0",
    "source_files": "AppUpgradable.playground/Sources/AppUpgradable.swift"
}

Pin It on Pinterest

Share This