Latest 1.0.2
Homepage https://github.com/younatics/AppUpdater
License MIT
Platforms ios 9.0, requires ARC
Frameworks UIKit
Authors

Version
Carthage Compatible
License: MIT
Platform
Build Status
Swift 4.2
iOS 9.0+

❗️Check your update with one line of code

Update available Update unavailable
available unavailable

Requirements

AppUpdater is written in Swift 4.2 Compatible with iOS 9.0+

Usage

AppUpdater.showUpdateAlert()

// force update.
AppUpdater.showUpdateAlert(isForce: true)

You can also use some methods listed below

Methods

Function Parameter Return
showUpdateAlert isForce
isUpdateAvailable Bool
versionAndDownloadUrl (version: String, downloadUrl: String)?

Installation

Cocoapods

pod 'AppUpdater'

Carthage

github "younatics/AppUpdater"

References

Please tell me or make pull request if you use this library in your application :)

MotionBook

Author

younatics
Twitter

License

AppUpdater is available under the MIT license. See the LICENSE file for more info.

Latest podspec

{
    "name": "AppUpdater",
    "version": "1.0.2",
    "summary": "AppUpdater in iOS!",
    "description": "AppUpdater in iOS! Use AppUpdater!!",
    "screenshots": [],
    "homepage": "https://github.com/younatics/AppUpdater",
    "license": {
        "type": "MIT",
        "file": "LICENSE"
    },
    "authors": {
        "Seungyoun Yi": "[email protected]"
    },
    "social_media_url": "https://twitter.com/younatics",
    "source": {
        "git": "https://github.com/younatics/AppUpdater.git",
        "tag": "1.0.2"
    },
    "source_files": "AppUpdater/*.swift",
    "platforms": {
        "ios": "9.0"
    },
    "frameworks": "UIKit",
    "pod_target_xcconfig": {
        "SWIFT_VERSION": "4.2"
    },
    "requires_arc": true
}

Pin It on Pinterest

Share This