Latest 1.0.0
Homepage https://github.com/BiAtoms/App.swift
License MIT
Platforms ios 8.0
Dependencies Material, Moya, MoyaSugar, SwiftyJSON, SnapKit, SwiftyUserDefaults, RxCocoa
Authors

Platform iOS
Cocoapods Compatible

A bunch of components/code that I use. Abstracts away api access and simplifies many many ui related things (TableViewController, CollectionViewController, Theming, UserDefaults).

Requires swift 3.

Installation

CocoaPods

CocoaPods is a dependency manager for Cocoa projects. You can install it with the following command:

$ gem install cocoapods

To integrate App.swift into your Xcode project using CocoaPods, specify it in your Podfile:

source 'https://github.com/CocoaPods/Specs.git'
target '<Your Target Name>' do
  pod 'App.swift', '~> 1.0'
end

Then, run the following command:

$ pod install

Manually

Just drag and drop the files in the Sources folder.

Authors

See also the list of contributors who participated in this project.

License

This project is licensed under the MIT License – see the LICENSE file for details

Latest podspec

{
    "name": "App.swift",
    "version": "1.0.0",
    "summary": "A bunch of components/code that I use frequently.",
    "homepage": "https://github.com/BiAtoms/App.swift",
    "license": {
        "type": "MIT",
        "file": "LICENSE"
    },
    "authors": {
        "Orkhan Alikhanov": "[email protected]"
    },
    "source": {
        "git": "https://github.com/BiAtoms/App.swift.git",
        "tag": "1.0.0"
    },
    "module_name": "AppSwift",
    "platforms": {
        "ios": "8.0"
    },
    "source_files": "Sources/*.swift",
    "dependencies": {
        "Material": [
            "2.10.1"
        ],
        "Moya": [
            "8.0.5"
        ],
        "MoyaSugar": [
            "0.4.1"
        ],
        "SwiftyJSON": [
            "3.1.4"
        ],
        "SnapKit": [
            "3.2.0"
        ],
        "SwiftyUserDefaults": [
            "3.0.0"
        ],
        "RxCocoa": [
            "3.6.1"
        ]
    },
    "pushed_with_swift_version": "3.1"
}

Pin It on Pinterest

Share This