Latest 0.0.2
Homepage https://github.com/Ama4Q/AMACalendar
License MIT
Platforms ios 9.0, requires ARC
Authors
AMACalendar
This is a Chinese Calendar.
The project AMACalendar is for Bmemo to write and it refer to the Daysquare. So, the need of Bmemo, the support of the lunar calendar.

============
CocoaPods
Swift Package Manager
License
Platform

Requirements

  • Xcode 8+
  • swift 3.0+
  • iOS 9.0+

Usage

let calendar = calendarView(frame: CGRect(x: 10,
                                          y: 50, 
                                      width: UIScreen.main.bounds.width - 20, 
                                     height: 280))

calendar.addTarget(self, action: #selector(calendarChange), for: .valueChanged)
view.addSubview(calendar)
@objc fileprivate func calendarChange(view: calendarView) {
    let formatter = DateFormatter()
    formatter.dateFormat = "YYYY-MM-dd"
    print(formatter.string(from: view.selectedDate!.0, view.selectedDate!.1)
}

Installation

  • Cocoapods
pod 'AMACalendar', ~> 0.0.2

Latest podspec

{
    "name": "AMACalendar",
    "version": "0.0.2",
    "summary": "This is a Chinese calendar.",
    "homepage": "https://github.com/Ama4Q/AMACalendar",
    "license": "MIT",
    "authors": {
        "Ama.Qiu": "[email protected]"
    },
    "source": {
        "git": "https://github.com/Ama4Q/AMACalendar.git",
        "tag": "0.0.2"
    },
    "platforms": {
        "ios": "9.0"
    },
    "pod_target_xcconfig": {
        "SWIFT_VERSION": "3.0"
    },
    "source_files": "Sources/CLib/*.swift",
    "resources": "Sources/CLib/AMACalendar.bundle",
    "requires_arc": true,
    "pushed_with_swift_version": "3.0"
}

Pin It on Pinterest

Share This