Latest 15.2.0
Homepage https://github.com/sunbohong/AlipaySDK
License MIT
Platforms ios 8.0
Dependencies UTDID
Frameworks SystemConfiguration, CoreTelephony, QuartzCore, CoreText, CoreGraphics, UIKit, Foundation, CFNetwork, CoreMotion

AlipaySDK

AlipaySDK

UTDID 是 阿里系的一个基础库,用于产生唯一设备id。大部分的阿里系SDK依赖该库。
为了保证编译通过(防止符号丢失和符号冲突),需要确保有且只有一个类库中包含 UTDID 的源码。

AlipaySDK 下载自: https://doc.open.alipay.com/doc2/detail.htm?treeId=54&articleId=104509&docType=1

文档的更新时间:2016/08/17

SDK更新日志:

iOS版本号:v15.2.0
修改时间:2016-08-23

  1. 增加支付宝支付和授权2.0体系服务;
  2. 完全兼容1.0体系,授权和支付接口保持不变;
  3. 订单组装问题修复。

install

pod 'AlipaySDK_No_UTDID_SUN', '~> 15.2.0'

或者

pod 'AlipaySDK_SUN', '~> 15.2.0'

因为 cocoapods 的限制,所有的项目必须编译通过才能发布,所以该项目依赖了 UTDID 库。
请注意是否需要防止符号冲突。

Latest podspec

{
    "name": "AlipaySDK_No_UTDID_SUN",
    "version": "15.2.0",
    "summary": "u652fu4ed8u5b9du652fu4ed8sdk",
    "description": "u652fu4ed8u5b9dsdkuff08u975eu5b98u65b9u7ef4u62a4uff09",
    "homepage": "https://github.com/sunbohong/AlipaySDK",
    "license": "MIT",
    "authors": "Alipay",
    "social_media_url": "https://doc.open.alipay.com/doc2/detail.htm?treeId=54&articleId=104509&docType=1",
    "platforms": {
        "ios": "8.0"
    },
    "source": {
        "git": "https://github.com/sunbohong/AlipaySDK.git",
        "tag": "15.2.0"
    },
    "vendored_frameworks": "AlipaySDK_No_UTDID/AlipaySDK.framework",
    "resources": "AlipaySDK_No_UTDID/AlipaySDK.bundle",
    "frameworks": [
        "SystemConfiguration",
        "CoreTelephony",
        "QuartzCore",
        "CoreText",
        "CoreGraphics",
        "UIKit",
        "Foundation",
        "CFNetwork",
        "CoreMotion"
    ],
    "libraries": [
        "c++",
        "z"
    ],
    "dependencies": {
        "UTDID": []
    }
}

Pin It on Pinterest

Share This