Latest 4.0
Homepage https://github.com/karthikAdaptavant/Alertify
License MIT
Platforms ios 10.0
Authors

Version
License
Platform

Feature

  • Method chain.
  • Can add multiple actions at once.
  • UITextField support.
  • Image support
  • iPad support(Action Sheet, popover).
  • Can change title/message/button text/ background color without using private APIs.
  • Can change title/message’s alignment without using private APIs.

Requirements

  • iOS 10.0+
  • Xcode 8.1+
  • Swift 3.0+

Installation

Alertify is available through CocoaPods. To install
it, simply add the following line to your Podfile:

pod 'Alertify'
        Alertify.actionSheet(message: nil, anchorView: sender)
                .action(.default("Hello"), image: #imageLiteral(resourceName: "chat"))
                .action(.default("Info"), image: #imageLiteral(resourceName: "info"))
                .action(.cancel("None"))
                .finally { action, index in
                      if action.style == .cancel {
                         return
                       }
                    }
                  .show(on: self)

Author

karthikAdaptavant, [email protected]

License

Alertify is available under the MIT license. See the LICENSE file for more info.

Latest podspec

{
    "name": "Alertify",
    "version": "4.0",
    "swift_version": "4.0",
    "summary": "A Eligant and Simple sugar for ActionSheet and AlertController.",
    "homepage": "https://github.com/karthikAdaptavant/Alertify",
    "license": {
        "type": "MIT",
        "file": "LICENSE"
    },
    "authors": {
        "karthikAdaptavant": "[email protected]"
    },
    "source": {
        "git": "https://github.com/karthikAdaptavant/Alertify.git",
        "tag": "4.0"
    },
    "platforms": {
        "ios": "10.0"
    },
    "source_files": "Alertify/Classes/**/*"
}

Pin It on Pinterest

Share This